blob: 4de129d008dd71824253264d2a79b6138d2be93d [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="0dc2876505851c2a448030fe88fbb351906f5f31"
CROS_WORKON_TREE=("19c459c4803e83d8ee5a56601def950ee6fb6cec" "3c6f0a290b022c6c50aa16ec5ea8478413dbc97b" "271149b9f1e2617df41a5968210b918f9c716bd3")
CROS_WORKON_PROJECT="chromiumos/third_party/kernel"
CROS_WORKON_LOCALNAME="kernel/v5.4"
CROS_WORKON_EGIT_BRANCH="chromeos-5.4"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
# Narrow the workon scope to just files referenced by the turbostat
# Makefile:
# https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-4.14/tools/power/x86/turbostat/Makefile#12
CROS_WORKON_SUBTREE="arch/x86/include/asm tools/include tools/power/x86/turbostat"
inherit cros-sanitizers cros-workon toolchain-funcs
HOMEPAGE="https://www.kernel.org/"
DESCRIPTION="Intel processor C-state and P-state reporting tool"
LICENSE="GPL-2"
SLOT="0/0"
KEYWORDS="*"
IUSE="-asan"
RDEPEND="sys-libs/libcap:="
DEPEND="${RDEPEND}"
domake() {
emake -C tools/power/x86/turbostat \
BUILD_OUTPUT="$(cros-workon_get_build_dir)" DESTDIR="${D}" \
CC="$(tc-getCC)" "$@"
}
src_configure() {
sanitizers-setup-env
default
}
src_compile() {
domake
}
src_install() {
domake install
}