blob: ee4eb53c0683de0abf169f3da28614891e447390 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="edc59f7812ca3aa1b5e304d2db7ee4cc44d26482"
CROS_WORKON_TREE="fbf628de87ea86d3fba4071ef23d6e467d04e503"
CROS_WORKON_PROJECT="chromiumos/third_party/toolchain-utils"
CROS_WORKON_LOCALNAME="toolchain-utils"
inherit cros-workon
DESCRIPTION="Compilation and runtime tests for toolchain"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/toolchain-utils/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
RDEPEND="
app-misc/pax-utils
dev-lang/python
sys-devel/binutils
"
src_install() {
local tc_dir="/usr/$(get_libdir)/${PN}"
local dit_dir="${tc_dir}/debug_info_test"
insinto ${tc_dir}
doins -r debug_info_test
fperms a+x ${dit_dir}/debug_info_test.py
dosym ${dit_dir}/debug_info_test.py /usr/bin/debug_info_test
newbin afdo_redaction/redact_profile.py redact_textual_afdo_profile
newbin afdo_redaction/remove_indirect_calls.py remove_indirect_calls
newbin afdo_redaction/remove_cold_functions.py remove_cold_functions
}