blob: 36ac037f14eabe48c566c7c9c2576296b8bb5b28 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="1cf1d1ceda64e0b81170f8454fd5ecca311667d5"
CROS_WORKON_TREE="2e32d2a5a79f8e88be91b44b40a65211c6ea4dae"
CROS_WORKON_PROJECT="chromiumos/third_party/coreboot"
DESCRIPTION="lp0 resume blob for Tegra"
HOMEPAGE="http://www.coreboot.org"
LICENSE="GPL-2"
KEYWORDS="-* arm arm64"
IUSE=""
RDEPEND=""
DEPEND=""
CROS_WORKON_LOCALNAME="coreboot"
inherit cros-workon
src_compile() {
emake -C src/soc/nvidia/tegra132/lp0 \
GCC_PREFIX="${CHOST}-" || \
die "tegra_lp0_resume build failed"
}
src_install() {
insinto /lib/firmware/tegra13x/
doins src/soc/nvidia/tegra132/lp0/tegra_lp0_resume.fw
}