blob: 03ab2f9f345155a09af5a5813f144d13fd2ac651 [file] [log] [blame]
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
inherit distutils-r1
DESCRIPTION="Fork of MySQL-python"
HOMEPAGE="https://pypi.org/project/mysqlclient/ https://github.com/PyMySQL/mysqlclient-python"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.post1.tar.gz -> ${PF}.tar.gz"
S="${WORKDIR}/${P}.post1"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="*"
IUSE="doc"
RDEPEND="
!dev-python/mysql-python
dev-db/mariadb-connector-c[mysqlcompat]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
DOCS=( README.md doc/{FAQ,MySQLdb}.rst )
python_compile_all() {
use doc && sphinx-build -b html doc doc/_build/
}
python_install_all() {
use doc && local HTML_DOCS=( doc/_build/. )
distutils-r1_python_install_all
}