blob: 7490dc1776011e593fe8a9eef7f5610dd485f17a [file] [log] [blame]
# Copyright 2010 Chromium OS Authors
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
CROS_WORKON_COMMIT="1cf1d1ceda64e0b81170f8454fd5ecca311667d5"
CROS_WORKON_TREE="2e32d2a5a79f8e88be91b44b40a65211c6ea4dae"
CROS_WORKON_PROJECT="chromiumos/third_party/coreboot"
CROS_WORKON_LOCALNAME="coreboot"
inherit cros-workon toolchain-funcs
DESCRIPTION="Superiotool allows you to detect which Super I/O you have on your mainboard, and it can provide detailed information about the register contents of the Super I/O."
HOMEPAGE="http://www.coreboot.org/Superiotool"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="sys-apps/pciutils"
DEPEND="${RDEPEND}"
src_compile() {
emake -C util/superiotool CC="$(tc-getCC)"
}
src_install() {
emake -C util/superiotool DESTDIR="${D}" install
}