blob: 995e62a5d70bf59ed3b608e67723895bb6796074 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=6
CROS_WORKON_PROJECT="chromiumos/third_party/tlsdate"
CROS_WORKON_LOCALNAME="tlsdate"
inherit cros-workon cros-rust
DESCRIPTION="Rust D-Bus bindings for tlsdate."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/tlsdate/+/master/"
LICENSE="BSD-Google"
SLOT="0/${PVR}"
KEYWORDS="~*"
RDEPEND=""
DEPEND="${RDEPEND}
chromeos-base/chromeos-dbus-bindings-rust:=
=dev-rust/dbus-0.6*:=
"
src_unpack() {
cros-workon_src_unpack
cros-rust_src_unpack
}
src_compile() {
ecargo_build
use test && ecargo_test --no-run
}
src_test() {
if use x86 || use amd64; then
ecargo_test
else
elog "Skipping rust unit tests on non-x86 platform"
fi
}
src_install() {
cros-rust_publish "${PN}" "$(cros-rust_get_crate_version)"
}