blob: d747492bfdefd38a9acb014c9a2fd864d51a56f1 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="6f9011123f3656c45bb34148673aa110a22326b3"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "49e3b5c529d012af19cb326eec9cf346538d4459" "c37af7d99913a584dbfb1b64fdb83acb19e91c20" "309b7116bd1f5aeb3ece4e1d90ce13f61b7e1b4b" "049eedf136293a1ab81617017200cb31032eb384" "6cdd3e4e16d9890ff8b5fe897e4cf5a94620c315" "aa0612733aca2d5ffa65470f07408228b473ebdb" "791c6808b4f4f5f1c484108d66ff958d65f8f1e3")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/hal/usb camera/include camera/mojo chromeos-config common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/hal/usb"
inherit cros-camera cros-workon platform
DESCRIPTION="Chrome OS USB camera HAL v3."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
RDEPEND="
chromeos-base/cros-camera-android-deps
chromeos-base/cros-camera-libs
dev-libs/re2
media-libs/libsync
chromeos-base/chromeos-config-tools"
DEPEND="${RDEPEND}
media-libs/libyuv
virtual/pkgconfig"
src_install() {
platform_src_install
cros-camera_dohal "${OUT}/lib/libcamera_hal.so" usb.so
}
platform_pkg_test() {
local tests=(
image_processor_test
)
local test_bin
for test_bin in "${tests[@]}"; do
platform_test run "${OUT}/${test_bin}"
done
}