blob: 4e6b20db61b101eef047d7e95ab29de42e4a5bea [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="795b81ff0fcf530f9b559d839078638addac7e83"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "168989869210014aaca0170db8cd6d04c6a38ca4" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml .gn"
PLATFORM_SUBDIR="ml"
inherit cros-workon platform
DESCRIPTION="Command line interface to machine learning service for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/ml"
LICENSE="BSD-Google"
KEYWORDS="*"
SLOT="0/0"
RDEPEND="
chromeos-base/chrome-icu:=
chromeos-base/metrics:=
chromeos-base/ml:=
sci-libs/tensorflow:=
"
DEPEND="
${RDEPEND}
"
src_install() {
dobin "${OUT}"/ml_cmdline
}
platform_pkg_test() {
platform_test "run" "${OUT}/ml_cmdline_test"
}