blob: 8c0e5ae11430c0416c23aa6a305917858ffb5dbe [file] [log] [blame]
# Copyright 2021 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/include camera/gpu camera/common common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/gpu/tests"
inherit cros-workon platform
DESCRIPTION="Chrome OS camera GPU-related tests"
LICENSE="BSD-Google"
KEYWORDS="~*"
BDEPEND="virtual/pkgconfig"
RDEPEND="
chromeos-base/cros-camera-android-deps:=
chromeos-base/cros-camera-libs:=
dev-cpp/gtest:=
virtual/opengles:=
"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers:=
"
src_configure() {
cros_optimize_package_for_speed
platform_src_configure
}