| # Copyright 2017 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="7" |
| |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_LOCALNAME="../platform2" |
| CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/hal/usb camera/include camera/tools common-mk" |
| CROS_WORKON_OUTOFTREE_BUILD="1" |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| |
| PLATFORM_SUBDIR="camera/tools/generate_camera_profile" |
| |
| inherit cros-camera cros-workon platform |
| |
| DESCRIPTION="Runtime detect the number of cameras on device to generate |
| corresponding media_profiles.xml." |
| |
| LICENSE="BSD-Google" |
| SLOT="0" |
| KEYWORDS="~*" |
| |
| RDEPEND="" |
| |
| DEPEND="${RDEPEND} |
| virtual/pkgconfig" |
| |
| src_install() { |
| platform_src_install |
| |
| dobin "${OUT}/generate_camera_profile" |
| } |