blob: e6a94e1048be86ed265e69cba781e8f9a8c595fc [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk ureadahead-diff .gn"
PLATFORM_SUBDIR="ureadahead-diff"
inherit cros-workon platform
DESCRIPTION="Calculate common part and difference of two ureadahead packs"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/ureadahead-diff"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="~*"
src_install() {
dobin "${OUT}"/ureadahead-diff
}
platform_pkg_test() {
platform_test "run" "${OUT}/ureadahead-diff_testrunner"
}