blob: 609b9c8725ba8d5c17524bb41c187537d4e5e5b6 [file] [log] [blame]
# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
CROS_WORKON_COMMIT="16fc4ef243ca343956a9ff287fde729592ae8750"
CROS_WORKON_TREE="26e984b6205ab9684bc709846aa1ac4659fdd7c2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="init/upstart/test-init"
inherit cros-workon
DESCRIPTION="Additional upstart jobs that will be installed on test images"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/init/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="+encrypted_stateful tpm2"
src_unpack() {
cros-workon_src_unpack
S+="/init"
}
src_install() {
insinto /etc/init
doins upstart/test-init/*.conf
insinto /usr/share/cros
doins upstart/test-init/*_utils.sh
if use encrypted_stateful && use tpm2; then
insinto /etc/init
doins upstart/test-init/encrypted_stateful/create-system-key.conf
insinto /usr/share/cros
doins upstart/test-init/encrypted_stateful/system_key_utils.sh
fi
}