blob: d47d1c660a5d327ace567044ec3a0f2608f0dfff [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="c142078820d0707858873cedb290a78d36f531af"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "7cd3aa8e49fcb501797fc2d50cf36fe52964dcde" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/myfiles .gn"
inherit cros-workon
DESCRIPTION="Container to run Android's MyFiles daemon."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/myfiles"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="chromeos-base/mount-passthrough
!<chromeos-base/chromeos-cheets-scripts-0.0.2-r470
"
src_install() {
insinto /etc/init
doins arc/myfiles/arc-myfiles.conf
doins arc/myfiles/arc-myfiles-default.conf
doins arc/myfiles/arc-myfiles-read.conf
doins arc/myfiles/arc-myfiles-write.conf
}