| # Copyright 2012 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_REPO="${CROS_GIT_HOST_URL}" |
| #CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk verity .gn" |
| CROS_WORKON_DESTDIR="${S}/platform2" |
| CROS_WORKON_EGIT_BRANCH="main" |
| |
| PLATFORM_SUBDIR="verity" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="File system integrity image generator for Chromium OS" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/verity/" |
| |
| LICENSE="BSD-Google GPL-2" |
| KEYWORDS="~*" |
| |
| PATCHES=( |
| "${FILESDIR}/support-new-dm-verity-format.patch" |
| "${FILESDIR}/0001-Add-version-to-PrintTable-and-GetTable.patch" |
| ) |
| |
| src_install() { |
| platform_src_install |
| } |
| |
| platform_pkg_test() { |
| platform test_all |
| } |