| # Copyright 2022 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_USE_VCSID="1" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| # TODO(crbug.com/809389): Avoid directly including headers from other packages. |
| CROS_WORKON_SUBTREE="common-mk libhwsec libhwsec-foundation metrics trunks u2fd .gn" |
| |
| PLATFORM_SUBDIR="u2fd/client" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="U2FHID library used by the internal corp U2F library" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/u2fd/client/" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="fuzzer cr50_onboard ti50_onboard" |
| |
| COMMON_DEPEND=" |
| chromeos-base/libhwsec:= |
| chromeos-base/session_manager-client:= |
| dev-libs/openssl:= |
| " |
| |
| RDEPEND="${COMMON_DEPEND}" |
| |
| DEPEND="${COMMON_DEPEND} |
| chromeos-base/chromeos-ec-headers:= |
| >=chromeos-base/protofiles-0.0.43:= |
| chromeos-base/system_api:= |
| " |
| |
| BDEPEND=" |
| dev-libs/protobuf |
| " |
| |
| platform_pkg_test() { |
| platform test_all |
| } |