| # Copyright 2019 The ChromiumOS Authors |
| # Use of this source code is governed by a BSD-style license that can be |
| # found in the LICENSE file. |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk libhwsec libhwsec-foundation tpm_softclear_utils trunks .gn" |
| |
| PLATFORM_SUBDIR="tpm_softclear_utils" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Utilities for soft-clearing TPM. This package resides in test images only." |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/tpm_softclear_utils/" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="test tpm tpm_dynamic tpm2" |
| REQUIRED_USE=" |
| tpm_dynamic? ( tpm tpm2 ) |
| !tpm_dynamic? ( ?? ( tpm tpm2 ) ) |
| " |
| |
| RDEPEND=" |
| tpm2? ( |
| chromeos-base/trunks:= |
| ) |
| tpm? ( |
| app-crypt/trousers:= |
| ) |
| chromeos-base/libhwsec-foundation:= |
| dev-libs/protobuf:= |
| " |
| |
| DEPEND="${RDEPEND} |
| tpm2? ( |
| chromeos-base/chromeos-ec-headers:= |
| chromeos-base/system_api:= |
| chromeos-base/trunks:=[test?] |
| ) |
| " |
| |
| platform_pkg_test() { |
| platform test_all |
| } |