| # Copyright 2016 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| # TODO(https://crbug.com/809389) |
| CROS_WORKON_SUBTREE="common-mk metrics timberslide .gn" |
| |
| PLATFORM_SUBDIR="timberslide" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="EC log concatenator for Chromium OS" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/timberslide/" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="" |
| |
| RDEPEND=" |
| >=chromeos-base/metrics-0.0.1-r3152:= |
| dev-libs/re2:= |
| " |
| |
| DEPEND="${RDEPEND}" |
| |
| platform_pkg_test() { |
| platform test_all |
| } |