| # Copyright 2021 The ChromiumOS Authors |
| # Use of this source code is governed by a BSD-style license that can be |
| # found in the LICENSE file. |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT=("c963fbbda8b77d108d55ddaf773ae9154b4b1ba7" "b57eeae0e31abe42972e453c6ed3598b9f1b8a69") |
| CROS_WORKON_TREE="b3503965fd190d6b0d14f1cd141f2f2ed8987dfc" |
| CROS_WORKON_PROJECT=( |
| "chromiumos/platform/tast-tests" |
| "chromiumos/platform/fw-testing-configs" |
| ) |
| CROS_WORKON_LOCALNAME=( |
| "platform/tast-tests" |
| "platform/tast-tests/src/chromiumos/tast/remote/firmware/data/fw-testing-configs" |
| ) |
| CROS_WORKON_DESTDIR=( |
| "${S}" |
| "${S}/src/chromiumos/tast/remote/firmware/data/fw-testing-configs" |
| ) |
| |
| # There are symlinks between remote data to local data, so we can't make the |
| # subtree "src/chromiumos/tast/remote". |
| # TODO(oka): have a clear separation between local and remote, and make that |
| # happen. |
| CROS_WORKON_SUBTREE=("src/chromiumos/tast") |
| |
| inherit cros-workon tast-bundle-data |
| |
| DESCRIPTION="Data files for remote Tast tests" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast-tests" |
| |
| LICENSE="BSD-Google GPL-3" |
| SLOT="0/0" |
| KEYWORDS="*" |
| |
| DEPEND="sys-firmware/ap-firmware-config:=" |
| RDEPEND="!<chromeos-base/tast-remote-tests-cros-0.0.2" |
| |
| src_install() { |
| tast-bundle-data_src_install |
| insinto /usr/share/tast/data/chromiumos/tast/remote/bundles/cros/firmware/data |
| doins /usr/share/ap_firmware_config/fw-config.json |
| } |