blob: 28acda6029936e654f723fdd79cf88cca70fd909 [file] [log] [blame]
# Copyright 2018 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="58a6d0f11c54183d5efa9935420306adbb4c4562"
CROS_WORKON_TREE="89db79d2862292b3e848a1bb3525e8e13616a6bc"
CROS_WORKON_PROJECT="chromiumos/platform/tast"
CROS_WORKON_LOCALNAME="platform/tast"
CROS_GO_BINARIES=(
"go.chromium.org/tast/core/cmd/local_test_runner"
)
CROS_GO_TEST=(
"go.chromium.org/tast/core/cmd/local_test_runner/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
inherit cros-go cros-workon
DESCRIPTION="Runner for local integration tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
app-arch/tar
!chromeos-base/tast-common
"
src_prepare() {
# Disable cgo and PIE on building Tast binaries. See:
# https://crbug.com/976196
# https://github.com/golang/go/issues/30986#issuecomment-475626018
export CGO_ENABLED=0
export GOPIE=0
default
}