| # Copyright 2022 The ChromiumOS Authors |
| # Use of this source code is governed by a BSD-style license that can be |
| # found in the LICENSE file. |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_SUBTREE="common-mk runtime_probe .gn" |
| |
| PLATFORM_NATIVE_TEST="yes" |
| PLATFORM_SUBDIR="runtime_probe/client" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Runtime Probe D-Bus client library for ChromiumOS" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/runtime_probe/" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="" |
| |
| BDEPEND=" |
| chromeos-base/chromeos-dbus-bindings |
| " |
| |
| # Workaround to rebuild this package on the chromeos-dbus-bindings update. |
| # Please find the comment in chromeos-dbus-bindings for its background. |
| DEPEND=" |
| chromeos-base/chromeos-dbus-bindings:= |
| " |
| |
| RDEPEND=" |
| chromeos-base/runtime_probe |
| " |
| |
| src_install() { |
| platform_src_install |
| platform_install_dbus_client_lib "runtime_probe" |
| } |