blob: aacb7537601be4a366ea20f7bec231d4000f2248 [file] [log] [blame]
# Copyright 2019 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_MANUAL_UPREV=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk rendernodehost .gn"
PLATFORM_SUBDIR="rendernodehost"
WANT_LIBCHROME="no"
inherit cros-workon platform
DESCRIPTION="host service for render node forwarding"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/rendernodehost/"
LICENSE="BSD-Google"
KEYWORDS="~*"
DEPEND="x11-libs/libdrm:="
src_install() {
platform_src_install
dolib.a "${OUT}"/librendernodehost.a
}