blob: c024f054f14871b1f16bc884b1229c05a80b176c [file] [log] [blame]
# Copyright 2019 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="941152648f66366af7662e9cf40cd3294a03a977"
CROS_WORKON_TREE=("de893318afddde7f89666376b8f346ea40e2fdf7" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk rendernodehost .gn"
PLATFORM_SUBDIR="rendernodehost"
WANT_LIBCHROME="no"
inherit cros-workon platform
DESCRIPTION="host service for render node forwarding"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/rendernodehost/"
LICENSE="BSD-Google"
KEYWORDS="*"
DEPEND="x11-libs/libdrm:="
src_install() {
platform_src_install
dolib.a "${OUT}"/librendernodehost.a
}