| # Copyright 2023 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk printscanmgr .gn" |
| |
| PLATFORM_SUBDIR="printscanmgr" |
| |
| inherit cros-workon platform user |
| |
| DESCRIPTION="Chrome OS printing and scanning daemon" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/printscanmgr/" |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="fuzzer" |
| |
| COMMON_DEPEND=" |
| chromeos-base/minijail:= |
| " |
| |
| RDEPEND=" |
| ${COMMON_DEPEND} |
| dev-libs/protobuf:= |
| sys-apps/dbus:= |
| " |
| |
| DEPEND="${COMMON_DEPEND} |
| chromeos-base/lorgnette-client:= |
| chromeos-base/system_api:=[fuzzer?] |
| " |
| |
| BDEPEND=" |
| chromeos-base/chromeos-dbus-bindings |
| chromeos-base/minijail |
| " |
| |
| pkg_preinst() { |
| enewuser printscanmgr |
| enewgroup printscanmgr |
| } |
| |
| src_install() { |
| platform_src_install |
| |
| # Install fuzzers. |
| local fuzzer_component_id="167231" |
| platform_fuzzer_install "${S}"/OWNERS "${OUT}"/cups_uri_helper_utils_fuzzer \ |
| --comp "${fuzzer_component_id}" |
| } |
| |
| platform_pkg_test() { |
| platform test_all |
| } |