| # Copyright 2020 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="7" |
| |
| CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c" |
| CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "4376098c685982a6b43bac65b18b49b18da4227f" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6") |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_DESTDIR="${S}/platform2" |
| CROS_WORKON_SUBTREE="common-mk pciguard .gn" |
| |
| PLATFORM_SUBDIR="pciguard" |
| |
| inherit cros-workon platform user |
| |
| DESCRIPTION="Chrome OS External PCI device security daemon" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/pciguard/" |
| |
| LICENSE="BSD-Google" |
| SLOT=0 |
| KEYWORDS="*" |
| |
| DEPEND=" |
| chromeos-base/session_manager-client:= |
| chromeos-base/system_api:= |
| " |
| |
| pkg_preinst() { |
| enewuser pciguard |
| enewgroup pciguard |
| cros-workon_pkg_setup |
| } |
| |
| platform_pkg_test() { |
| platform test_all |
| } |