| # Copyright 2020 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c" |
| CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "a203a66cdff42be84e2b855e8f691928087e59eb" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6") |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_DESTDIR="${S}/platform2" |
| CROS_WORKON_SUBTREE="common-mk ml_benchmark .gn" |
| |
| DESCRIPTION="Chrome OS ML Benchmarking Suite" |
| |
| PLATFORM_SUBDIR="ml_benchmark" |
| # Do not run test parallelly until unit tests are fixed. |
| # shellcheck disable=SC2034 |
| PLATFORM_PARALLEL_GTEST_TEST="no" |
| |
| inherit cros-workon platform |
| |
| # chromeos-base/ml_benchmark blocked due to package rename |
| RDEPEND=" |
| !chromeos-base/ml_benchmark |
| dev-libs/protobuf:= |
| dev-libs/re2:= |
| vulkan? ( media-libs/clvk ) |
| " |
| |
| DEPEND="${RDEPEND}" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| IUSE="vulkan" |
| |
| platform_pkg_test() { |
| platform test_all |
| } |