| # Copyright 2019 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="7" |
| |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk arc/vm/libvda .gn" |
| |
| PLATFORM_SUBDIR="arc/vm/libvda" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="libvda Chrome GPU tests" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/arc/vm/libvda" |
| |
| LICENSE="BSD-Google" |
| SLOT="0" |
| KEYWORDS="~*" |
| IUSE="" |
| |
| RDEPEND=" |
| media-libs/minigbm:= |
| " |
| |
| DEPEND=" |
| ${RDEPEND} |
| chromeos-base/system_api:= |
| " |
| |
| src_compile() { |
| platform "compile" "libvda_gpu_unittest" |
| } |
| |
| src_install() { |
| platform_src_install |
| |
| exeinto /usr/libexec/libvda-gpu-tests |
| doexe "${OUT}/libvda_gpu_unittest" |
| } |