blob: 47a759f82f2876be3bcba6e9085edc834015f6cf [file] [log] [blame]
# Copyright 2022 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk hwsec-optee-plugin libhwsec libhwsec-foundation .gn"
PLATFORM_SUBDIR="hwsec-optee-plugin"
inherit cros-workon platform
DESCRIPTION="Optee plugin for hardware security module."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/hwsec-optee-plugin/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="test"
COMMON_DEPEND="
chromeos-base/libhwsec:=[test?]
chromeos-base/optee_client:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
platform_pkg_test() {
platform test_all
}