| # Copyright 2022 The ChromiumOS Authors |
| # Use of this source code is governed by a BSD-style license that can be |
| # found in the LICENSE file. |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk hwsec-host-utils trunks .gn" |
| |
| PLATFORM_SUBDIR="hwsec-host-utils" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Hwsec-related host-only utilities." |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/hwsec-host-utils/" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="cros_host" |
| REQUIRED_USE="cros_host" |
| |
| COMMON_DEPEND=" |
| chromeos-base/trunks:= |
| app-crypt/trousers:= |
| " |
| RDEPEND="${COMMON_DEPEND}" |
| DEPEND="${COMMON_DEPEND}" |
| |
| platform_pkg_test() { |
| platform test_all |
| } |