| # Copyright 2018 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| # TODO(crbug.com/809389): Avoid directly including headers from other packages. |
| CROS_WORKON_SUBTREE="common-mk libhwsec libhwsec-foundation metrics u2fd .gn" |
| |
| PLATFORM_SUBDIR="u2fd/g2f_tools" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="G2F gnubby (U2F+GCSE) development and testing tools" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/u2fd" |
| |
| LICENSE="BSD-Google" |
| SLOT="0/0" |
| KEYWORDS="~*" |
| |
| COMMON_DEPEND=" |
| chromeos-base/u2fd:= |
| dev-libs/hidapi:= |
| " |
| |
| RDEPEND=" |
| ${COMMON_DEPEND} |
| dev-libs/protobuf:= |
| " |
| |
| DEPEND=" |
| ${COMMON_DEPEND} |
| chromeos-base/chromeos-ec-headers:= |
| chromeos-base/protofiles:= |
| chromeos-base/system_api:= |
| " |
| |
| platform_pkg_test() { |
| platform test_all |
| } |