| # Copyright 2021 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_SUBTREE="common-mk fusebox .gn" |
| |
| PLATFORM_SUBDIR="fusebox" |
| |
| inherit cros-workon platform user |
| |
| DESCRIPTION="FuseBox service" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/main/fusebox" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| |
| IUSE="test" |
| |
| COMMON_DEPEND=" |
| dev-libs/protobuf:= |
| sys-apps/dbus:= |
| =sys-fs/fuse-2.9*:= |
| " |
| |
| RDEPEND="${COMMON_DEPEND}" |
| |
| DEPEND="${COMMON_DEPEND} |
| chromeos-base/system_api |
| " |
| |
| src_install() { |
| platform_src_install |
| |
| dobin "${OUT}"/fusebox |
| } |
| |
| platform_pkg_test() { |
| local tests=(fusebox_test) |
| |
| local test_bin |
| for test_bin in "${tests[@]}"; do |
| platform_test "run" "${OUT}/${test_bin}" |
| done |
| } |