| # Copyright 2022 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="7" |
| |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_DESTDIR="${S}/platform2" |
| CROS_WORKON_SUBTREE="common-mk feature_usage metrics .gn" |
| |
| PLATFORM_SUBDIR="feature_usage" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Provides a unified approach to report feature usage events" |
| |
| LICENSE="BSD-Google" |
| SLOT="0/0" |
| KEYWORDS="~*" |
| |
| RDEPEND=" |
| chromeos-base/metrics:= |
| " |
| |
| DEPEND=" |
| ${RDEPEND} |
| " |
| |
| src_install() { |
| platform_src_install |
| |
| # Install the static library |
| dolib.a "${OUT}"/libfeature_usage_static.a |
| |
| # Install the header |
| insinto "/usr/include/feature_usage" |
| doins feature_usage_metrics.h |
| |
| # Install the pc file |
| insinto "/usr/$(get_libdir)/pkgconfig" |
| doins "${OUT}/obj/feature_usage/libfeature_usage.pc" |
| } |
| |
| platform_pkg_test() { |
| platform test_all |
| } |