| # Copyright 2022 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="7" |
| |
| CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c" |
| CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "0a6d97056ccad46af343769331531b94a8113dd1" "faa5b8036561b66b5b9d79ea1af8a95927a0ae0f" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6") |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_DESTDIR="${S}/platform2" |
| CROS_WORKON_SUBTREE="common-mk feature_usage metrics .gn" |
| |
| PLATFORM_SUBDIR="feature_usage" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Provides a unified approach to report feature usage events" |
| |
| LICENSE="BSD-Google" |
| SLOT="0/0" |
| KEYWORDS="*" |
| |
| RDEPEND=" |
| chromeos-base/metrics:= |
| " |
| |
| DEPEND=" |
| ${RDEPEND} |
| " |
| |
| src_install() { |
| platform_src_install |
| |
| # Install the static library |
| dolib.a "${OUT}"/libfeature_usage_static.a |
| |
| # Install the header |
| insinto "/usr/include/feature_usage" |
| doins feature_usage_metrics.h |
| |
| # Install the pc file |
| insinto "/usr/$(get_libdir)/pkgconfig" |
| doins "${OUT}/obj/feature_usage/libfeature_usage.pc" |
| } |
| |
| platform_pkg_test() { |
| platform test_all |
| } |