| # Copyright 2022 Gentoo Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk discod libhwsec-foundation metrics .gn" |
| |
| PLATFORM_SUBDIR="discod" |
| |
| inherit cros-workon platform user |
| |
| DESCRIPTION="Disk Control daemon for ChromiumOS" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/discod/" |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="" |
| |
| COMMON_DEPEND=" |
| chromeos-base/libhwsec-foundation:= |
| chromeos-base/metrics:= |
| sys-apps/rootdev:= |
| " |
| |
| RDEPEND="${COMMON_DEPEND}" |
| |
| DEPEND=" |
| ${COMMON_DEPEND} |
| chromeos-base/system_api:= |
| " |
| |
| pkg_preinst() { |
| enewuser "disco" |
| enewgroup "disco" |
| } |
| |
| platform_pkg_test() { |
| platform test_all |
| } |