| # Copyright 2022 Gentoo Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c" |
| CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "db25d2b94d09b2eae3d8a1efc00b6232c5abefa5" "0d9d2046eb78dc8620f7594f245298f9fd964832" "faa5b8036561b66b5b9d79ea1af8a95927a0ae0f" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6") |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk discod libhwsec-foundation metrics .gn" |
| |
| PLATFORM_SUBDIR="discod" |
| |
| inherit cros-workon platform user |
| |
| DESCRIPTION="Disk Control daemon for ChromiumOS" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/discod/" |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| IUSE="" |
| |
| COMMON_DEPEND=" |
| chromeos-base/libhwsec-foundation:= |
| chromeos-base/metrics:= |
| sys-apps/rootdev:= |
| " |
| |
| RDEPEND="${COMMON_DEPEND}" |
| |
| DEPEND=" |
| ${COMMON_DEPEND} |
| chromeos-base/system_api:= |
| " |
| |
| pkg_preinst() { |
| enewuser "disco" |
| enewgroup "disco" |
| } |
| |
| platform_pkg_test() { |
| platform test_all |
| } |