| # Copyright 2022 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk diagnostics .gn" |
| PLATFORM_SUBDIR="diagnostics/testing" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Test utility for cros-healthd" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/diagnostics" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="" |
| |
| DEPEND=" |
| chromeos-base/diagnostics:= |
| " |
| |
| platform_pkg_test() { |
| platform test_all |
| } |