blob: 0c46f7c62ab341e39c3f5a69aea34499c6112b19 [file] [log] [blame]
# Copyright 2014 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="c93d4259c7541e09ac7c0afe970e74236ea09950"
CROS_WORKON_TREE="c36e986f289ad9d3fe59d5a245ae3c793aaa006d"
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME="platform/dev"
CROS_WORKON_OUTOFTREE_BUILD="1"
inherit cros-workon
DESCRIPTION="Server to cache Chromium OS build artifacts from Google Storage."
HOMEPAGE="http://dev.chromium.org/chromium-os/how-tos-and-troubleshooting/using-the-dev-server"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
dev-lang/python
dev-python/protobuf-python
dev-python/cherrypy
net-misc/gsutil
!<chromeos-base/cros-devutils-1
"
DEPEND="
dev-python/psutil
"
src_install() {
emake install DESTDIR="${D}"
}
src_test() {
# Run the unit tests.
./run_unittests || die
}