blob: b3293d4fa800f35d8c81eabb697ce7daaedca4ce [file] [log] [blame]
# Copyright 2012 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
CROS_WORKON_COMMIT="83358570b9a2feef4c79c237077e614f931716c1"
CROS_WORKON_TREE="e2ac84620f30f5b8a273babe06b8ef520b9be200"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="init/upstart/test-init"
inherit cros-workon
DESCRIPTION="Additional upstart jobs that will be installed on test images"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/init/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="+encrypted_stateful tpm2"
# File cryptohome-dbus-perf.conf moved from hwsec-test-utils.
RDEPEND="!<chromeos-base/hwsec-test-utils-0.0.1-r83"
src_unpack() {
cros-workon_src_unpack
S+="/init"
}
src_install() {
insinto /etc/init
doins upstart/test-init/*.conf
insinto /usr/share/cros
doins upstart/test-init/factory_utils.sh
if use encrypted_stateful && use tpm2; then
insinto /etc/init
doins upstart/test-init/encrypted_stateful/create-system-key.conf
fi
}