blob: d2bd2e8d33b7706bdc7c503ca05af86887858cdf [file] [log] [blame]
# Copyright 2018 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("a46e9d233b0d094256459f613101070f84133a6a" "f5e2cf960b53ced95e376e741a260babb924b3a1")
CROS_WORKON_TREE=("e591eadf63f5562675875b0f8569e61b895efb6d" "3aa1e82b07bce781053fba839f46baf2f4131f47")
CROS_WORKON_PROJECT=(
"chromiumos/platform/ec"
"chromiumos/platform/ec"
)
CROS_WORKON_LOCALNAME=(
"platform/ec"
"platform/cr50"
)
CROS_WORKON_DESTDIR=(
"${S}/platform/ec"
"${S}/platform/cr50"
)
CROS_WORKON_EGIT_BRANCH=(
"main"
"cr50_stab"
)
CROS_WORKON_INCREMENTAL_BUILD=1
inherit cros-workon
DESCRIPTION="Exported headers from the embedded controller codebase."
HOMEPAGE="https://www.chromium.org/chromium-os/ec-development"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND=""
DEPEND=""
# No configuration or compilation necessary. This is a header only package.
src_configure() { :; }
src_compile() { :; }
src_install() {
dir_ec=${CROS_WORKON_DESTDIR[0]}
dir_cr50=${CROS_WORKON_DESTDIR[1]}
insinto /usr/include/trunks/cr50_headers/
doins "${dir_cr50}"/include/u2f.h
doins "${dir_cr50}"/include/ap_ro_status.h
doins "${dir_cr50}"/board/cr50/tpm2/virtual_nvmem.h
insinto /usr/include/chromeos/ec/
doins "${dir_ec}"/include/ec_commands.h
doins "${dir_ec}"/include/ec_cmd_api.h
doins "${dir_ec}"/include/panic_defs.h
doins "${dir_ec}"/util/cros_ec_dev.h
}