| # Copyright 2020 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT="8b6e11a069e490c761cdab7ab3ff59434806cd9c" |
| CROS_WORKON_TREE=("41d899585b7a07ea908a0cca2944a7b8a4d13655" "685561d7556c0ae10dacd31616929c30e0a11852" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6") |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_SUBTREE="common-mk cfm-dfu-notification .gn" |
| CROS_WORKON_DESTDIR="${S}/platform2" |
| |
| PLATFORM_SUBDIR="cfm-dfu-notification" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Library to send firmware update notifications to CFM" |
| |
| LICENSE="BSD-Google" |
| SLOT="0/0" |
| KEYWORDS="*" |
| |
| RDEPEND="" |
| DEPEND="${RDEPEND}" |
| |
| src_install() { |
| platform_src_install |
| |
| dolib.so "${OUT}"/lib/libcfm_dfu_notification.so |
| |
| "${S}"/platform2_preinstall.sh "${PV}" "/usr/include/chromeos" "${OUT}" |
| insinto "/usr/$(get_libdir)/pkgconfig" |
| doins "${OUT}"/cfm-dfu-notification.pc |
| |
| insinto "/usr/include/chromeos/cfm-dfu-notification" |
| doins ./*.h |
| } |
| |
| platform_pkg_test() { |
| platform_test "run" "${OUT}"/cfm_dfu_notification_test |
| } |