blob: aace4fe94e193a1b3db22a5b02f2e014a8ce490a [file] [log] [blame]
# Copyright 2014 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5f7a1ed1448a260baad1f16532f179f2600f1597"
CROS_WORKON_TREE="a4655a9e5ae73d3fcae6694b56e0806723cf5220"
PYTHON_COMPAT=( python3_{6..9} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon autotest libchrome cros-sanitizers python-any-r1
DESCRIPTION="Security autotests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="*"
# Enable autotest by default.
IUSE="+autotest -chromeless_tests -chromeless_tty containers +seccomp selinux"
RDEPEND="
!<chromeos-base/autotest-tests-0.0.3
"
DEPEND="${RDEPEND}"
IUSE_TESTS="
"
IUSE="${IUSE} ${IUSE_TESTS}"
AUTOTEST_FILE_MASK="*.a *.tar.bz2 *.tbz2 *.tgz *.tar.gz"
cros_pre_src_configure_use_sanitizers() {
sanitizers-setup-env
}