| # Copyright 2016 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT="5f7a1ed1448a260baad1f16532f179f2600f1597" |
| CROS_WORKON_TREE="a4655a9e5ae73d3fcae6694b56e0806723cf5220" |
| PYTHON_COMPAT=( python3_{6..9} ) |
| |
| CROS_WORKON_PROJECT="chromiumos/third_party/autotest" |
| CROS_WORKON_LOCALNAME="third_party/autotest/files" |
| |
| inherit autotest cros-workon flag-o-matic python-any-r1 |
| |
| DESCRIPTION="Public ARC autotests" |
| |
| LICENSE="BSD-Google" |
| SLOT="0" |
| KEYWORDS="*" |
| |
| RDEPEND=" |
| dev-python/pyxattr |
| chromeos-base/chromeos-chrome |
| chromeos-base/autotest-chrome |
| chromeos-base/telemetry |
| " |
| |
| DEPEND="${RDEPEND}" |
| |
| IUSE=" |
| +autotest |
| " |
| |
| src_prepare() { |
| # Telemetry tests require the path to telemetry source to exist in order to |
| # build. Copy the telemetry source to a temporary directory that is writable, |
| # so that file removals in Telemetry source can be performed properly. |
| export TMP_DIR="$(mktemp -d)" |
| cp -r "${SYSROOT}/usr/local/telemetry" "${TMP_DIR}" |
| export PYTHONPATH="${TMP_DIR}/telemetry/src/third_party/catapult/telemetry" |
| autotest_src_prepare |
| } |