| # Copyright 2018 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="arc/adbd common-mk .gn" |
| |
| PLATFORM_SUBDIR="arc/adbd" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Container to run Android's adbd proxy." |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/arc/adbd" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="+seccomp fuzzer arcvm" |
| |
| RDEPEND=" |
| chromeos-base/minijail |
| " |
| |
| src_install() { |
| platform_src_install |
| |
| # Install fuzzers. |
| # fuzzer_component_id is unknown/unlisted |
| platform_fuzzer_install "${S}"/OWNERS "${OUT}"/arc-adbd-setup-config-fs-fuzzer |
| platform_fuzzer_install "${S}"/OWNERS "${OUT}"/arc-adbd-setup-function-fs-fuzzer |
| platform_fuzzer_install "${S}"/OWNERS "${OUT}"/arc-adbd-create-pipe-fuzzer |
| } |