blob: 7730bd60ef358c62b58fe08f1735c69c694ce5f2 [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
# TODO(crbug.com/914263): camera/hal/usb is unnecessary for this build but is
# workaround for unexpected sandbox behavior.
CROS_WORKON_SUBTREE=".gn camera/build camera/hal/usb camera/hal/usb_v1 camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/hal/usb_v1"
inherit cros-workon platform user
DESCRIPTION="ARC camera service. The service is in charge of accessing camera
device. It uses linux domain socket (/run/camera/camera.sock) to build a
synchronous channel."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="~*"
IUSE="-asan"
RDEPEND="
!chromeos-base/arc-camera-service
media-libs/cros-camera-libcamera_timezone"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_install() {
dobin "${OUT}/arc_camera_service"
insinto /etc/dbus-1/system.d
doins org.chromium.ArcCamera.conf
insinto /etc/init
doins init/arc-camera.conf
}
pkg_preinst() {
enewuser "arc-camera"
enewgroup "arc-camera"
}