blob: 2b85249fbfb439ca02030ec5a9b98f3bccab35c3 [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="f1856c6f39a5cacd367cfc24926d6773c97a7aec"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "d58be6324ba2a1d0452d23bafb39c869c5ed2cd6" "65e27114752b7ab8f4cede066f4a586059bd7e61" "c8cf946e212b8355bc1f53f077004c814532e904" "584f7cc8998d8fa6c9b041054ce4a352016f477a" "eec5ce9cfadd268344b02efdbec7465fbc391a9e")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
# TODO(crbug.com/914263): camera/hal/usb is unnecessary for this build but is
# workaround for unexpected sandbox behavior.
CROS_WORKON_SUBTREE=".gn camera/build camera/hal/usb camera/hal/usb_v1 camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/hal/usb_v1"
inherit cros-workon platform user
DESCRIPTION="ARC camera service. The service is in charge of accessing camera
device. It uses linux domain socket (/run/camera/camera.sock) to build a
synchronous channel."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan"
RDEPEND="
!chromeos-base/arc-camera-service
media-libs/cros-camera-libcamera_timezone"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_install() {
dobin "${OUT}/arc_camera_service"
insinto /etc/dbus-1/system.d
doins org.chromium.ArcCamera.conf
insinto /etc/init
doins init/arc-camera.conf
}
pkg_preinst() {
enewuser "arc-camera"
enewgroup "arc-camera"
}