| # Copyright 2012 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_COMMIT="01d4fc123b3631b1628bc86f9271e278b0e34634" |
| CROS_WORKON_TREE="c0c663b809f2677dd18231c92a2e037fb2af65fa" |
| CROS_WORKON_PROJECT="chromiumos/third_party/daisydog" |
| CROS_WORKON_OUTOFTREE_BUILD="1" |
| |
| inherit cros-workon toolchain-funcs user |
| |
| DESCRIPTION="Simple HW watchdog daemon" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/daisydog" |
| |
| LICENSE="GPL-2" |
| SLOT="0/0" |
| KEYWORDS="*" |
| IUSE="" |
| |
| src_prepare() { |
| mkdir -p "$(cros-workon_get_build_dir)" |
| default |
| } |
| |
| src_configure() { |
| tc-export CC |
| default |
| } |
| |
| _emake() { |
| emake -C "$(cros-workon_get_build_dir)" \ |
| top_srcdir="${S}" -f "${S}"/Makefile "$@" |
| } |
| |
| src_compile() { |
| _emake |
| } |
| |
| src_install() { |
| _emake DESTDIR="${D}" install |
| } |
| |
| pkg_preinst() { |
| enewuser watchdog |
| enewgroup watchdog |
| } |