| # Copyright 2020 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f" |
| CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "4aad1773476a4fd5d6d51a5332a66ad94dd3aa13" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb") |
| CROS_WORKON_LOCALNAME="../platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_DESTDIR="${S}/platform2" |
| CROS_WORKON_SUBTREE="common-mk ml_core .gn" |
| |
| DESCRIPTION="Chrome OS ML Core Feature Library" |
| |
| PLATFORM_SUBDIR="ml_core" |
| |
| inherit cros-workon platform |
| |
| RDEPEND=" |
| " |
| DEPEND="${RDEPEND} |
| " |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| IUSE="" |
| |
| src_install() { |
| platform_src_install |
| dolib.so "${OUT}"/lib/libcros_ml_core.so |
| } |
| |
| platform_pkg_test() { |
| platform test_all |
| } |