blob: d637d8e5ed5a15d4a7c642cb360214844d0b5e8b [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="b05e4a6b92b2cfe608b6cd8d5d37168680fc080e"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "d4688b618445182a5925e02136792a8973362e7c" "20ed8021024637e492670d20fa5969a2ad75e4b6" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk tpm_softclear_utils trunks .gn"
PLATFORM_SUBDIR="tpm_softclear_utils"
inherit cros-workon platform
DESCRIPTION="Utilities for soft-clearing TPM. This package resides in test images only."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/tpm_softclear_utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test tpm tpm2"
REQUIRED_USE="tpm2? ( !tpm )"
RDEPEND="
tpm2? (
chromeos-base/trunks:=
)
!tpm2? (
app-crypt/trousers:=
)
"
DEPEND="${RDEPEND}
tpm2? (
chromeos-base/system_api:=
chromeos-base/trunks:=[test?]
)
"
src_install() {
# Installs the utilities executable.
insinto /usr/local/bin
doins "${OUT}/tpm_softclear"
chmod u+x "${D}/usr/local/bin/tpm_softclear"
}
platform_pkg_test() {
platform_test "run" "${OUT}/tpm_softclear_utils_testrunner"
}