blob: ce89d20f07da7d7eee9299f44a520f666efbe1f1 [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk power_manager .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="power_manager/client"
inherit cros-workon platform
DESCRIPTION="Power manager DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/power_manager/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="cros_host"
DEPEND=""
RDEPEND=""
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "power_manager"
}