blob: 3f6a90c95bc6198aec4b2de624c17a785721bc4f [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="a643fd773cf6ad93eb8bc66162c0fc56d7a7e406"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "f89d62f067e47fc70b2a70153729f6d4e5067414" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk power_manager .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="power_manager/client"
inherit cros-workon platform
DESCRIPTION="Power manager DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/power_manager/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="cros_host"
DEPEND=""
RDEPEND=""
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "power_manager"
}