blob: 80fd46a75c8c24096792789b19710f16a0febe0f [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="67b30051d9937f721cc5b3f5d18e31d159829e2a"
CROS_WORKON_TREE="6af6dff2eb93d08a39ac84f045b89a4e485d94e9"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="biod/study"
PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit cros-workon python-r1
DESCRIPTION="Chromium OS Fingerprint user study software"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/biod/study"
LICENSE="BSD-Google"
KEYWORDS="*"
# The fingerprint study can optionally make use of the private package
# virtual/chromeos-fpmcu-test, which holds the C+python fputils lib.
# This library is also used for factory tests, thus it was labeled fpmcu-test.
DEPEND=""
RDEPEND="
${PYTHON_DEPS}
chromeos-base/ec-utils
dev-python/cherrypy[${PYTHON_USEDEP}]
dev-python/python-gnupg[${PYTHON_USEDEP}]
dev-python/ws4py[${PYTHON_USEDEP}]
virtual/chromeos-fpmcu-test
"
src_unpack() {
cros-workon_src_unpack
S+="/biod/study"
}
src_install() {
# install the study local server
exeinto /opt/google/fingerprint_study
newexe study_serve.py study_serve
# Content to serve
insinto /opt/google/fingerprint_study/html
doins html/index.html
doins html/bootstrap-3.3.7.min.css
doins html/fingerprint.svg
insinto /etc/init
doins init/fingerprint_study.conf
doins init/syslog_fingerprint_study.conf
insinto /etc/bash/bashrc.d
doins shell-audit.sh
insinto /etc/rsyslog.d
doins rsyslog.fpstudy-audit.conf
}